Follow

Technical - Minimum Hardware Requirements

To run Nightmare Guardians, your device must be able to run at least iOS 7, as well as all later versions of iOS. If your device does not support at least iOS 7, then you will not be able to play Night Defenders.

Supported Operating Systems

  • iOS 7+

Supported Devices

  • iPhone 4S
  • iPhone 5
  • iPhone 5C
  • iPhone 5S
  • iPhone 6
  • iPhone 6 Plus
  • iPad 2
  • iPad (3rd Generation)
  • iPad (4th Generation)
  • iPad Air
  • iPad Air 2
  • iPad Mini 2
  • iPad Mini 3
Was this article helpful?
21 out of 21 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk